M1 Dealer Site  
Search

Any term All terms

Main Menu
Home
FAQs
Bulletin Board (Forums)
Site Search
Downloads **
Email Elk Tech Support
M1 Training Videos
RP Training Videos
XEP Training Videos
XSP Training Videos
Webinar Training Videos
Go to Main Elk Website

View Topic
Forums :: ElkRP "Software for Installer Programming" :: ElkRP2 Crash On Startup

| Reply Reply |
ElkRP2 Crash On Startup
Posted by ultrajones on 01/18/2010 09:19 AM

I just installed ElkRP2 2.0.4 on a Windows 7 64 bit PC that has the .Net 2.0 framework installed and is fully up 2 date. When I double-click the icon on the desktop, the program crashes and provides the following details:

Description:
  Stopped working

Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	elkrp2.exe
  Problem Signature 02:	2.0.4.15470
  Problem Signature 03:	4b321d32
  Problem Signature 04:	ElkRP2
  Problem Signature 05:	2.0.4.15470
  Problem Signature 06:	4b321d32
  Problem Signature 07:	35
  Problem Signature 08:	e0
  Problem Signature 09:	System.InvalidOperationException
  OS Version:	6.1.7600.2.0.0.768.3
  Locale ID:	1033

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:Windowssystem32en-USerofflps.txt

Regards,
Ultrajones



Edited by ultrajones on 01/18/2010 09:24 AM

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 01/18/2010 09:23 AM

IMPORTANT! ElkRP2 is not currently compatible with Microsoft Windows 7. Elk is well aware of this issue and plans to add Support for Windows 7 soon

Re: ElkRP2 Crash On Startup
Posted by epsteing on 01/18/2010 10:50 PM

It seems to work fine with Windows 7 using Windows XP compatibility mode.

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 01/19/2010 08:39 AM

epsteing, do you have a 32 or 64 Bit PC?

Re: ElkRP2 Crash On Startup
Posted by mohansen on 01/19/2010 11:51 PM

My RP2 crashes on trying to connect to the M1. I am running XP. I don't see any log messages. It looks like it flashes something on the screen but I can't tell what it shows. RP2 comes up and converted my database and shows the system details. It just doesn't allow me to connect.

Re: ElkRP2 Crash On Startup
Posted by mohansen on 01/20/2010 10:21 AM

I disabled my security software and now I get a error message after starting RP2. ElkRP Error Report - 01/20/2010 08:20 Error Number: 429 Description: Retrieving the COM class factory for component with CLSID {B7F63409-038D-11D6-B70B-000103E7BDEC} failed due to the following error: 80040154. Executable: ElkRP:Main Module: frmMain Function: Form_Load ElkRP Version: 1.06.0026 M1G.dll Version: 4.05.0030 M1.dll Version: 4.05.0030 EZ8.dll Version: 4.05.0030 ElkComm.dll Version: 1, 2, 10, 10 ConvertDB.dll Version: 1.02.0010 ElkSafe.dll Version: 1.00.0002 ErrorDlg.dll Version: 1.00.0010 Microsoft Windows NT 5.1.2600 Service Pack 3

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 01/20/2010 11:22 AM

Please Post if you have Windows XP, Vista or 7 as well as 32 or 64 Bit

Re: ElkRP2 Crash On Startup
Posted by mohansen on 01/20/2010 01:00 PM

I think the original poster indicated he has Windows 7 64 bit. My system is Windows XP.

Re: ElkRP2 Crash On Startup
Posted by epsteing on 01/23/2010 10:14 AM

I'm running Windows 7 32-bit. I right clicked the EXE, ran the "Troubleshoot compatibility" wizard, which set it to XP compatibility mode, and it's running perfectly. I can connect to M1G panels and modify settings.

Re: ElkRP2 Crash On Startup
Posted by snhroc on 01/31/2010 08:47 PM

Mine is crashing with Windows 7 64 bit. Won't run in compatibility mode either.

Re: ElkRP2 Crash On Startup
Posted by mohansen on 02/02/2010 04:49 PM

I am still getting an error when I try to launch Elk RP2. I am running XP. ElkRP Error Report - 02/02/2010 14:43 Error Number: 429 Description: Retrieving the COM class factory for component with CLSID {B7F63409-038D-11D6-B70B-000103E7BDEC} failed due to the following error: 80040154. Executable: ElkRP:Main Module: frmMain Function: Form_Load ElkRP Version: 1.06.0026 M1G.dll Version: 4.05.0030 M1.dll Version: 4.05.0030 EZ8.dll Version: 4.05.0030 ElkComm.dll Version: 1, 2, 10, 10 ConvertDB.dll Version: 1.02.0010 ElkSafe.dll Version: 1.00.0002 ErrorDlg.dll Version: 1.00.0010 Microsoft Windows NT 5.1.2600 Service Pack 3

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 02/02/2010 05:06 PM

Do you have ELK-RP 1.6.26 Installed?

Re: ElkRP2 Crash On Startup
Posted by mohansen on 02/02/2010 10:53 PM

Yes. I do have 1.6.26 installed.

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 02/03/2010 11:25 AM

Try the following with the software closed click Start, Control Panel, Add/Remove Programs, select RP 1.6.26, click Remove when prompted select "Repair". Once the Repair is complete reboot your PC and retest.

Re: ElkRP2 Crash On Startup
Posted by mohansen on 02/03/2010 05:01 PM

I made the changes. Note that you have to click CHANGE instead of REMOVE and it asked for the 1.6.26 Full Install exe file. I will reboot later and test.

Re: ElkRP2 Crash On Startup
Posted by mohansen on 02/03/2010 08:06 PM

I rebooted and still have the same issue. I get the error when first launching Elk RP2.

Re: ElkRP2 Crash On Startup
Posted by bradweeks on 02/04/2010 10:40 AM

In your C:Documents and SettingsAll UsersApplication DataRP Locate your Elkaccts.mdb and Elkaccts2.mdb right click copy and save to another location for example your Desktop. Next completely uninstall ELK-RP 1.6.26 and Elk-RP2 2.0.4. Once the uninstall is complete search your local c drive for an RP Folder and if found delete. Restart your PC. Next download a fresh new Install of ELK-RP 1.6.26 and test opening the program. If RP 1.6.26 opens without any problems then download RP2 2.0.4 and test opening the program.

Edited by bradweeks on 02/04/2010 01:29 PM

Re: ElkRP2 Crash On Startup
Posted by sparta440 on 03/24/2010 08:50 AM

Im running Windows 7 64-bit Pro with Vitrual XP mode installed. I installed RP2 in XP and it seems to run fine, but when i connect (via ethernet) to a panel i have around 30 seconds to a minute after connection, the control panel will disconnect. When connected i can send any changes made before the panel disconnects me. Any one else run into this problem? I will be testing the direct connection sometime today and report my findings.

| Reply Reply |

What's Related
These might interest you as well
FAQ

Form Generator

Web Pages